3v4l.org

run code in 200+ PHP versions simultaneously
<?php echo preg_replace('/[^\pL\pM]*/iu', '', 'áéíóú');
Output for 4.4.0 - 4.4.9, 5.0.5 - 5.1.6, 5.5.27 - 5.5.35, 5.6.11 - 7.2.6
áéíóú
Output for 5.2.9 - 5.5.26, 5.6.8 - 5.6.10
����ú
Output for 5.2.0 - 5.2.8
Output for 4.3.11, 5.0.0 - 5.0.4
Warning: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 3 in /in/ueAJv on line 3
Output for 4.3.0 - 4.3.10
Warning: Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 3 in /in/ueAJv on line 3