3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php trigger_error( 'Please use XPath::evaluate() not XPath::query().', E_USER_DEPRECATED );
Output for 7.0.0 - 7.1.0
Deprecated: Please use XPath::evaluate() not XPath::query(). in /in/t9rNk on line 3
Output for hhvm-3.10.0 - 3.12.0
Output for 5.3.0 - 5.6.28
Deprecated: Please use XPath::evaluate() not XPath::query(). in /in/t9rNk on line 4
Output for 4.3.0 - 5.2.17
Notice: Use of undefined constant E_USER_DEPRECATED - assumed 'E_USER_DEPRECATED' in /in/t9rNk on line 4 Warning: Invalid error type specified in /in/t9rNk on line 4