3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $string='دد'; echo preg_replace('#(?:^[^\pL]*)|(?:[^\pL]*$)#u','',$string);
Output for 4.4.0 - 4.4.9, 5.0.5 - 5.1.6, 5.5.27 - 5.5.36, 5.6.11 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
دد
Output for 5.4.0 - 5.4.4, 5.4.7, 5.4.9 - 5.5.26, 5.6.0 - 5.6.10

Process exited with code 139.
Output for 5.2.0 - 5.3.29, 5.4.5 - 5.4.6, 5.4.8
Output for 4.3.11, 5.0.0 - 5.0.4
Warning: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 7 in /in/s1rB4 on line 3
Output for 4.3.0 - 4.3.10
Warning: Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 7 in /in/s1rB4 on line 3