3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php error_reporting(E_ALL); ini_set('display_errors', 1); $wsdl = 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl'; $options = array( 'stream_context' => stream_context_create(array( 'ssl' => array( 'verify_peer' => false))), ); $client = new SoapClient($wsdl, $options);
Output for 7.0.0 - 7.1.0
Fatal error: Uncaught Error: Class 'SoapClient' not found in /in/jC4WV:12 Stack trace: #0 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.4.0 - 5.6.21
Fatal error: Class 'SoapClient' not found in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.3.0 - 5.3.29
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->SoapClient('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.2.7 - 5.2.17
Notice: SoapClient::SoapClient(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/jC4WV on line 12 Warning: SoapClient::SoapClient(): I/O warning : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV on line 12 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->SoapClient('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.2.0 - 5.2.6
Notice: SoapClient::SoapClient(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/jC4WV on line 12 Warning: SoapClient::SoapClient(): I/O warning : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV on line 12 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->SoapClient('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.1.0 - 5.1.6
Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/jC4WV on line 12 Warning: SoapClient::__construct(): I/O warning : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV on line 12 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->__construct('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.0.4 - 5.0.5
Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/jC4WV on line 12 Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/jC4WV on line 12 Warning: I/O warning : failed to load external entity "https://webservices4.autotask.net/atservices/1.5/atws.wsdl" in /in/jC4WV on line 12 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->__construct('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.0.3
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' in /in/jC4WV:12 Stack trace: #0 /in/jC4WV(12): SoapClient->__construct('https://webserv...', Array) #1 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 5.0.0 - 5.0.2
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices4.autotask.net/atservices/1.5/atws.wsdl' in /in/jC4WV:12 Stack trace: #0 {main} thrown in /in/jC4WV on line 12
Process exited with code 255.
Output for 4.3.2 - 4.4.9
Fatal error: Cannot instantiate non-existent class: soapclient in /in/jC4WV on line 12
Process exited with code 255.
Output for 4.3.0 - 4.3.1
Fatal error: Cannot instantiate non-existent class: soapclient in /in/jC4WV on line 12