3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $t = OI; echo "<script>alert(\"$t\");</script>" ;
Output for 4.3.0 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
Notice: Use of undefined constant OI - assumed 'OI' in /in/gmrOo on line 2 <script>alert("OI");</script>