3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $_REQUEST=array(); $_REQUEST["username"]=" or username=\""; $_REQUEST["password"]=" or password=\""; echo "SELECT * from users where username=\"".$_REQUEST["username"]."\" and password=\"".$_REQUEST["password"]."\""; ?>
Output for 4.3.0 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
SELECT * from users where username=" or username="" and password=" or password=""