3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php declare (strict_types = 1); $doc = new \DOMDocument('1.0'); $doc->loadXML('<foo><bar>baz</bar></foo>'); $xpath = new \DOMXPath($doc); if (version_compare(PHP_VERSION, '7.0.2') === 0) { $node = $xpath->query('/foo')->item(0)->cloneNode(1); } else { $node = $xpath->query('/foo')->item(0)->cloneNode(true); }
based on RlGmZ
Output for 7.0.3 - 7.2.0
Output for 7.0.2
Fatal error: Uncaught TypeError: DOMNode::cloneNode() expects parameter 1 to be boolean, integer given in /in/ecRGh:11 Stack trace: #0 /in/ecRGh(11): DOMNode->cloneNode(1) #1 {main} thrown in /in/ecRGh on line 11
Process exited with code 255.
Output for 7.0.0 - 7.0.1
Fatal error: Uncaught TypeError: DOMNode::cloneNode() expects parameter 1 to be integer, boolean given in /in/ecRGh:13 Stack trace: #0 /in/ecRGh(13): DOMNode->cloneNode(true) #1 {main} thrown in /in/ecRGh on line 13
Process exited with code 255.
Output for 5.3.21 - 5.6.28
Warning: Unsupported declare 'strict_types' in /in/ecRGh on line 3