3v4l.org

run code in 300+ PHP versions simultaneously
<?php interface Middleware { /** * @param object $command * @param callable $next * * @return mixed */ public function execute($command, callable $next); } final class RegisterProcessedMessages implements Middleware { /** * {@inheritDoc} */ public function execute(object $command, callable $next): void { } }
based on q8Qnm
Output for 7.4.0 - 7.4.11, 8.0.0alpha1 - rc2
Fatal error: Declaration of RegisterProcessedMessages::execute(object $command, callable $next): void must be compatible with Middleware::execute($command, callable $next) in /in/dj5Up on line 19
Process exited with code 255.
Output for 7.1.0 - 7.1.33, 7.2.0 - 7.2.33, 7.3.0 - 7.3.23
Fatal error: Declaration of RegisterProcessedMessages::execute(object $command, callable $next): void must be compatible with Middleware::execute($command, callable $next) in /in/dj5Up on line 14
Process exited with code 255.