3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo htmlspecialchars('<script>alert("xss")</script>') . PHP_EOL;
Output for 4.3.10 - 4.4.9, 5.0.2 - 7.1.0
&lt;script&gt;alert(&quot;xss&quot;)&lt;/script&gt;
Output for 4.3.0 - 4.3.9, 5.0.0 - 5.0.1
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/d5rtX on line 3 &lt;script&gt;alert(&quot;xss&quot;)&lt;/script&gt;PHP_EOL