3v4l.org

run code in 300+ PHP versions simultaneously
<?php class YourFavoriteFrameworkClass28 { public function process($name) { } } class YourFavoriteFrameworkClass44 { public function process(string $name) { } } class Implementer extends YourFavoriteFrameworkClass44 { public function process($name, $newArgument) { } } $app = new Implementer();
Output for 8.0.0 - 8.0.12, 8.1rc1 - rc3
Fatal error: Declaration of Implementer::process($name, $newArgument) must be compatible with YourFavoriteFrameworkClass44::process(string $name) in /in/Znrnq on line 20
Process exited with code 255.
Output for 7.4.0 - 7.4.25
Warning: Declaration of Implementer::process($name, $newArgument) should be compatible with YourFavoriteFrameworkClass44::process(string $name) in /in/Znrnq on line 20
Output for 7.2.0 - 7.2.33, 7.3.0 - 7.3.31
Warning: Declaration of Implementer::process($name, $newArgument) should be compatible with YourFavoriteFrameworkClass44::process(string $name) in /in/Znrnq on line 23

preferences:
43.43 ms | 462 KiB | 5 Q