3v4l.org

run code in 300+ PHP versions simultaneously
<?php class Foo{ function method($a){ } } class Bar extends Foo{ function method(){ } }
Output for 8.0.0 - 8.0.30, 8.1.0 - 8.1.29, 8.2.0 - 8.2.20, 8.3.0 - 8.3.8
Fatal error: Declaration of Bar::method() must be compatible with Foo::method($a) in /in/YoDHq on line 8
Process exited with code 255.
Output for 7.4.0 - 7.4.33
Warning: Declaration of Bar::method() should be compatible with Foo::method($a) in /in/YoDHq on line 8
Output for 7.0.0 - 7.0.33, 7.1.0 - 7.1.33, 7.2.0 - 7.2.33, 7.3.0 - 7.3.33
Warning: Declaration of Bar::method() should be compatible with Foo::method($a) in /in/YoDHq on line 11
Output for 5.6.38
Strict Standards: Declaration of Bar::method() should be compatible with Foo::method($a) in /in/YoDHq on line 11

preferences:
236.23 ms | 402 KiB | 249 Q