3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php print_r(array_merge('asdf', array('foo', 'bar')));
Output for 5.2.3 - 5.6.28, 7.0.0 - 7.1.0
Warning: array_merge(): Argument #1 is not an array in /in/VeGcC on line 1
Output for hhvm-3.10.0 - 3.12.0
Warning: array_merge() expects parameter 1 to be array, string given in /in/VeGcC on line 1
Output for 5.0.0 - 5.2.2
<br /> <b>Warning</b>: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #1 is not an array in <b>/in/VeGcC</b> on line <b>1</b><br />
Output for 4.3.0 - 4.4.9
Array ( [0] => asdf [1] => foo [2] => bar )