3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php interface Foo { public function baz(Foo $foo); } interface Bar extends Foo { public function baz(Bar $foo); }
Output for 7.0.0 - 7.2.0
Fatal error: Declaration of Bar::baz(Bar $foo) must be compatible with Foo::baz(Foo $foo) in /in/V7V9Y on line 7
Process exited with code 255.
Output for 5.4.1 - 5.6.28
Fatal error: Declaration of Bar::baz() must be compatible with Foo::baz(Foo $foo) in /in/V7V9Y on line 7
Process exited with code 255.
Output for 5.3.17 - 5.3.29
Fatal error: Declaration of Bar::baz() must be compatible with that of Foo::baz() in /in/V7V9Y on line 7
Process exited with code 255.