3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $str = "Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)"; preg_match($str, ';', $matches); echo $matches;
Output for 5.2.0 - 5.6.21, 7.0.0 - 7.1.0
Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /in/UqfkL on line 5
Output for hhvm-3.10.0 - 3.12.0
Warning: Delimiter must not be alphanumeric or backslash in /in/UqfkL on line 5
Output for 4.3.11 - 5.1.6
Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /in/UqfkL on line 5 Array
Output for 4.3.0 - 4.3.10
Warning: Delimiter must not be alphanumeric or backslash in /in/UqfkL on line 5 Array