3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php if (!PHP_EOL) { echo "All is fine, PHP is still active"; } else { echo "PHP is EOL!!! Quick, migrate!"; }
Output for 4.3.10 - 4.4.9, 5.0.2 - 5.6.28, hhvm-3.12.0, 7.0.0 - 7.1.0
PHP is EOL!!! Quick, migrate!
Output for hhvm-3.10.0

Process exited with code 153.
Output for 4.3.0 - 4.3.9, 5.0.0 - 5.0.1
Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/TLACR on line 3 PHP is EOL!!! Quick, migrate!