3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $atservices_wsdl = "https://webservices.autotask.net/atservices/1.5/atws.wsdl"; $atservices_client = new SoapClient($atservices_wsdl); $zone_info = $atservices_client->getZoneInfo("TestUser"); print_r($zone_info); // review the returned object converted from SOAP response.
based on p1Lo1
Output for 7.0.0 - 7.1.0
Fatal error: Uncaught Error: Class 'SoapClient' not found in /in/Ruq2s:3 Stack trace: #0 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for hhvm-3.10.0 - 3.13.2
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP_ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl'
Process exited with code 255.
Output for 5.4.0 - 5.6.28
Fatal error: Class 'SoapClient' not found in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.3.0 - 5.3.29
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->SoapClient('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.2.7 - 5.2.17
Notice: SoapClient::SoapClient(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/Ruq2s on line 3 Warning: SoapClient::SoapClient(): I/O warning : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s on line 3 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->SoapClient('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.2.0 - 5.2.6
Notice: SoapClient::SoapClient(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/Ruq2s on line 3 Warning: SoapClient::SoapClient(): I/O warning : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s on line 3 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->SoapClient('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.1.1 - 5.1.6
Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/Ruq2s on line 3 Warning: SoapClient::__construct(): I/O warning : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s on line 3 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->__construct('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.1.0
Fatal error: fatal flex scanner internal error--end of buffer missed in /in/Ruq2s on line 7
Process exited with code 255.
Output for 5.0.4 - 5.0.5
Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/Ruq2s on line 3 Notice: SoapClient::__construct(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/Ruq2s on line 3 Warning: I/O warning : failed to load external entity "https://webservices.autotask.net/atservices/1.5/atws.wsdl" in /in/Ruq2s on line 3 Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->__construct('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.0.3
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' in /in/Ruq2s:3 Stack trace: #0 /in/Ruq2s(3): SoapClient->__construct('https://webserv...') #1 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 5.0.0 - 5.0.2
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://webservices.autotask.net/atservices/1.5/atws.wsdl' in /in/Ruq2s:3 Stack trace: #0 {main} thrown in /in/Ruq2s on line 3
Process exited with code 255.
Output for 4.3.2 - 4.4.9
Fatal error: Cannot instantiate non-existent class: soapclient in /in/Ruq2s on line 3
Process exited with code 255.
Output for 4.3.0 - 4.3.1
Fatal error: Cannot instantiate non-existent class: soapclient in /in/Ruq2s on line 3