3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo 'blah', PHP_EOL;
Output for 4.3.10 - 4.4.9, 5.0.2 - 5.6.21, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
blah
Output for 4.3.0 - 4.3.9, 5.0.0 - 5.0.1
blah Notice: Use of undefined constant PHP_EOL - assumed 'PHP_EOL' in /in/Qiarl on line 3 PHP_EOL