3v4l.org

run code in 300+ PHP versions simultaneously
<?php echo preg_replace('/[^\d-\.]/', '', '123abc');
Output for 7.3.0 - 7.3.21, 7.4.0 - 7.4.9, 8.0.0alpha1 - beta1
Warning: preg_replace(): Compilation failed: invalid range in character class at offset 4 in /in/NuLqI on line 3
Output for 5.6.0 - 5.6.40, 7.0.0 - 7.0.33, 7.1.0 - 7.1.33, 7.2.0 - 7.2.33
123