3v4l.org

run code in 300+ PHP versions simultaneously
<?php interface I { function foo(J $j); } interface J extends I { function foo(I $i); }
based on TSKhd
Output for 7.4.0 - 7.4.14, 8.0.0
Output for 7.0.0 - 7.0.33, 7.1.0 - 7.1.25, 7.2.0 - 7.2.33, 7.3.0 - 7.3.26
Fatal error: Declaration of J::foo(I $i) must be compatible with I::foo(J $j) in /in/MX0Cb on line 9
Process exited with code 255.
Output for 5.5.0 - 5.5.38, 5.6.0 - 5.6.38
Fatal error: Declaration of J::foo() must be compatible with I::foo(J $j) in /in/MX0Cb on line 9
Process exited with code 255.