3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo html_entity_decode( '&#39;', ENT_COMPAT, 'USASCII' );
Output for 5.4.0 - 7.1.0
Warning: html_entity_decode(): charset `USASCII' not supported, assuming utf-8 in /in/Lolct on line 2 &#39;
Output for 5.2.3 - 5.3.29
Warning: html_entity_decode(): charset `USASCII' not supported, assuming iso-8859-1 in /in/Lolct on line 2 &#39;
Output for 4.4.3 - 4.4.9, 5.0.5 - 5.2.2
<br /> <b>Warning</b>: html_entity_decode() [<a href='function.html-entity-decode'>function.html-entity-decode</a>]: charset `USASCII' not supported, assuming iso-8859-1 in <b>/in/Lolct</b> on line <b>2</b><br /> &#39;
Output for 5.0.0 - 5.0.4
<br /> <b>Warning</b>: html_entity_decode() [<a href='function.html-entity-decode'>function.html-entity-decode</a>]: charset `USASCII' not supported, assuming iso-8859-1 in <b>/in/Lolct</b> on line <b>2</b><br /> '
Output for 4.3.2 - 4.4.2
<br /> <b>Warning</b>: html_entity_decode(): charset `USASCII' not supported, assuming iso-8859-1 in <b>/in/Lolct</b> on line <b>2</b><br /> &#39;
Output for 4.3.0 - 4.3.1
<br /> <b>Warning</b>: html_entity_decode() [<a href='http://www.php.net/function.html-entity-decode'>function.html-entity-decode</a>]: charset `USASCII' not supported, assuming iso-8859-1 in <b>/in/Lolct</b> on line <b>2</b><br />
Process exited with code 139.