3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php if(in_array('jquery.js', ['jquery.js', 'bootsrap.js'])) var_dump('stupid'); if(in_array(['jquery', 'bootsrap'])) var_dump('oh php');
Output for 5.4.0 - 7.1.0
string(6) "stupid" Warning: in_array() expects at least 2 parameters, 1 given in /in/KtZ7D on line 3
Output for 4.4.2 - 4.4.9, 5.1.0 - 5.3.29
Parse error: syntax error, unexpected '[' in /in/KtZ7D on line 2
Process exited with code 255.
Output for 4.3.0 - 4.3.1, 4.3.5 - 4.4.1, 5.0.0 - 5.0.5
Parse error: parse error, unexpected '[' in /in/KtZ7D on line 2
Process exited with code 255.
Output for 4.3.2 - 4.3.4
Parse error: parse error in /in/KtZ7D on line 2
Process exited with code 255.