3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php version_compare(PHP_VERSION, '5.0.0', '>=') or die('SKIPPED'); $exts = array( 'dotnet', 'hw', 'swf', 'xslt', 'qtdom', 'i18n', 'w32api', 'notes', 'objaggregation', 'java', 'msession', 'fam', 'soap', ); foreach ($exts as $ext) { echo "{$ext}: "; try { ReflectionExtension::export('dotnet'); $success = true; } catch (ReflectionException $e) { $success = false; } echo ($success ? "AVAILABLE" : "-"); echo "\n"; }
Output for 5.0.0 - 5.6.28, 7.0.0 - 7.1.0
dotnet: - hw: - swf: - xslt: - qtdom: - i18n: - w32api: - notes: - objaggregation: - java: - msession: - fam: - soap: -
Output for hhvm-3.10.0 - 3.12.0
dotnet: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE hw: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE swf: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE xslt: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE qtdom: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE i18n: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE w32api: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE notes: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE objaggregation: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE java: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE msession: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE fam: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE soap: Extension [ <persistent> extension #0 dotnet version \{\} AVAILABLE
Output for 4.4.2 - 4.4.9
Parse error: syntax error, unexpected '{' in /in/FL3mh on line 22
Process exited with code 255.
Output for 4.3.0 - 4.3.1, 4.3.5 - 4.4.1
Parse error: parse error, unexpected '{' in /in/FL3mh on line 22
Process exited with code 255.
Output for 4.3.2 - 4.3.4
Parse error: parse error in /in/FL3mh on line 22
Process exited with code 255.