3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php print 'foo'; php?>
Output for 7.2.0 - 7.3.0rc4
foo Warning: Use of undefined constant php - assumed 'php' (this will throw an Error in a future version of PHP) in /in/BqjS7 on line 4
Output for 4.3.0 - 7.1.20
foo Notice: Use of undefined constant php - assumed 'php' in /in/BqjS7 on line 4