3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php function foo() { echo "called foo\n"; } class A {} new A(foo()); echo "are you sure?";
Output for hhvm-3.10.0 - 3.12.0, 7.1.0
called foo are you sure?
Output for 4.3.0 - 5.6.28, 7.0.0 - 7.0.14
are you sure?