3v4l.org

run code in 300+ PHP versions simultaneously
<?php $s['longDescription'] = 'replace these ***** not this* and *** this ** ****'; $blurb = preg_replace("/(?:(?<=\*)|(?=\*\*))\*/", "&#9733;", $s['longDescription']); echo $blurb;
Output for 4.3.0 - 4.3.11, 4.4.0 - 4.4.9, 5.0.0 - 5.0.5, 5.1.0 - 5.1.6, 5.2.0 - 5.2.17, 5.3.0 - 5.3.29, 5.4.0 - 5.4.45, 5.5.24 - 5.5.35, 5.6.8 - 5.6.28, 7.0.0 - 7.0.20, 7.1.0 - 7.1.20, 7.2.0 - 7.2.33, 7.3.12 - 7.3.28, 7.4.0 - 7.4.16, 8.0.0 - 8.0.3
replace these &#9733;&#9733;&#9733;&#9733;&#9733; not this* and &#9733;&#9733;&#9733; this &#9733;&#9733; &#9733;&#9733;&#9733;&#9733;