3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $code = substr(sha1(Rand(0,9999),0,4)); echo $code ; ?>
Output for 5.3.0 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
Warning: sha1() expects at most 2 parameters, 3 given in /in/8MV1C on line 2 Warning: substr() expects at least 2 parameters, 1 given in /in/8MV1C on line 2
Output for 5.0.0 - 5.2.17
Warning: sha1() expects at most 2 parameters, 3 given in /in/8MV1C on line 2 Warning: Wrong parameter count for substr() in /in/8MV1C on line 2
Output for 4.3.0 - 4.4.9
Warning: Wrong parameter count for sha1() in /in/8MV1C on line 2 Warning: Wrong parameter count for substr() in /in/8MV1C on line 2