3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $vc = version_compare('5.4', PHP_VERSION); $foo = version_compare(PHP_VERSION, '5.4.0', '>='); var_dump($vc, $foo, $vc === $foo);
Output for 5.4.0 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
int(-1) bool(true) bool(false)
Output for 4.3.0 - 5.3.29
int(1) bool(false) bool(false)