3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php if(version_compare(PHP_VERSION, '5.1.6') < 0) exit(htmlspecialchars('PHP 5.1.6 or newer is required. Your current version ('.PHP_VERSION.') does not meet this requirement.'));
Output for 5.1.6 - 7.1.0
Output for 5.1.5
PHP 5.1.6 or newer is required. Your current version (5.1.5) does not meet this requirement.
Output for 5.1.4
PHP 5.1.6 or newer is required. Your current version (5.1.4) does not meet this requirement.
Output for 5.1.3
PHP 5.1.6 or newer is required. Your current version (5.1.3) does not meet this requirement.
Output for 5.1.2
PHP 5.1.6 or newer is required. Your current version (5.1.2) does not meet this requirement.
Output for 5.1.1
PHP 5.1.6 or newer is required. Your current version (5.1.1) does not meet this requirement.
Output for 5.1.0
PHP 5.1.6 or newer is required. Your current version (5.1.0) does not meet this requirement.
Output for 5.0.5
PHP 5.1.6 or newer is required. Your current version (5.0.5) does not meet this requirement.
Output for 5.0.4
PHP 5.1.6 or newer is required. Your current version (5.0.4) does not meet this requirement.
Output for 5.0.3
PHP 5.1.6 or newer is required. Your current version (5.0.3) does not meet this requirement.
Output for 5.0.2
PHP 5.1.6 or newer is required. Your current version (5.0.2) does not meet this requirement.
Output for 5.0.1
PHP 5.1.6 or newer is required. Your current version (5.0.1) does not meet this requirement.
Output for 5.0.0
PHP 5.1.6 or newer is required. Your current version (5.0.0) does not meet this requirement.
Output for 4.4.9
PHP 5.1.6 or newer is required. Your current version (4.4.9) does not meet this requirement.
Output for 4.4.8
PHP 5.1.6 or newer is required. Your current version (4.4.8) does not meet this requirement.
Output for 4.4.7
PHP 5.1.6 or newer is required. Your current version (4.4.7) does not meet this requirement.
Output for 4.4.6
PHP 5.1.6 or newer is required. Your current version (4.4.6) does not meet this requirement.
Output for 4.4.5
PHP 5.1.6 or newer is required. Your current version (4.4.5) does not meet this requirement.
Output for 4.4.4
PHP 5.1.6 or newer is required. Your current version (4.4.4) does not meet this requirement.
Output for 4.4.3
PHP 5.1.6 or newer is required. Your current version (4.4.3) does not meet this requirement.
Output for 4.4.2
PHP 5.1.6 or newer is required. Your current version (4.4.2) does not meet this requirement.
Output for 4.4.1
PHP 5.1.6 or newer is required. Your current version (4.4.1) does not meet this requirement.
Output for 4.4.0
PHP 5.1.6 or newer is required. Your current version (4.4.0) does not meet this requirement.
Output for 4.3.11
PHP 5.1.6 or newer is required. Your current version (4.3.11) does not meet this requirement.
Output for 4.3.10
PHP 5.1.6 or newer is required. Your current version (4.3.10) does not meet this requirement.
Output for 4.3.9
PHP 5.1.6 or newer is required. Your current version (4.3.9) does not meet this requirement.
Output for 4.3.8
PHP 5.1.6 or newer is required. Your current version (4.3.8) does not meet this requirement.
Output for 4.3.7
PHP 5.1.6 or newer is required. Your current version (4.3.7) does not meet this requirement.
Output for 4.3.6
PHP 5.1.6 or newer is required. Your current version (4.3.6) does not meet this requirement.
Output for 4.3.5
PHP 5.1.6 or newer is required. Your current version (4.3.5) does not meet this requirement.
Output for 4.3.4
PHP 5.1.6 or newer is required. Your current version (4.3.4) does not meet this requirement.
Output for 4.3.3
PHP 5.1.6 or newer is required. Your current version (4.3.3) does not meet this requirement.
Output for 4.3.2
PHP 5.1.6 or newer is required. Your current version (4.3.2) does not meet this requirement.
Output for 4.3.1
PHP 5.1.6 or newer is required. Your current version (4.3.1) does not meet this requirement.
Output for 4.3.0
PHP 5.1.6 or newer is required. Your current version (4.3.0) does not meet this requirement.