3v4l.org

run code in 300+ PHP versions simultaneously
<?php interface A { public function foo(array $foo); } interface B extends A { public function foo($foo); }
Output for 7.2.0 - 7.2.33, 7.3.0 - 7.3.33, 7.4.0 - 7.4.27, 8.0.0 - 8.0.15, 8.1.0 - 8.1.2
Output for 7.0.33, 7.1.0 - 7.1.33
Fatal error: Declaration of B::foo($foo) must be compatible with A::foo(array $foo) in /in/4Lbfo on line 8
Process exited with code 255.
Output for 5.6.38
Fatal error: Declaration of B::foo() must be compatible with A::foo(array $foo) in /in/4Lbfo on line 8
Process exited with code 255.

preferences:
25.42 ms | 461 KiB | 5 Q