3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo end( explode( ':', array('tttt:pppp') ) );
Output for 7.0.0 - 7.1.0
Warning: explode() expects parameter 2 to be string, array given in /in/3dBi9 on line 2 Notice: Only variables should be passed by reference in /in/3dBi9 on line 2 Warning: end() expects parameter 1 to be array, null given in /in/3dBi9 on line 2
Output for hhvm-3.10.0 - 3.12.0
Warning: explode() expects parameter 2 to be string, array given in /in/3dBi9 on line 2 Warning: Invalid operand type was used: expecting an array in /in/3dBi9 on line 2
Output for 5.5.0 - 5.6.28
Warning: explode() expects parameter 2 to be string, array given in /in/3dBi9 on line 2 Strict Standards: Only variables should be passed by reference in /in/3dBi9 on line 2 Warning: end() expects parameter 1 to be array, null given in /in/3dBi9 on line 2
Output for 5.3.1 - 5.4.45
Warning: explode() expects parameter 2 to be string, array given in /in/3dBi9 on line 2 Warning: end() expects parameter 1 to be array, null given in /in/3dBi9 on line 2
Output for 4.3.0 - 5.0.4, 5.1.0 - 5.3.0
Array
Output for 5.0.5
<br /> <b>Fatal error</b>: Only variables can be passed by reference in <b>/in/3dBi9</b> on line <b>2</b><br />
Process exited with code 255.