3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php echo json_encode([ 'lts' => '2.3.21', 'latest' => '2.5.6', 'dev' => '2.6.0-beta1', '2.3' => '2.3.21', '2.5' => '2.5.6', '2.6' => '2.6.0-beta1', 'installable' => ['2.3.21', '2.5.6', ...] 'non_installable' => ['2.0.0', '2.0.1', ..., '2.1.0', ..., '2.4.0', ..., '2.5.0', '2.5.1', ...] ]);
Output for 5.4.0 - 5.4.35
Parse error: syntax error, unexpected '.', expecting ']' in /in/0tGOE on line 10
Process exited with code 255.
Output for 4.4.2 - 4.4.9, 5.1.0 - 5.3.29
Parse error: syntax error, unexpected '[', expecting ')' in /in/0tGOE on line 3
Process exited with code 255.
Output for 4.3.0 - 4.3.1, 4.3.5 - 4.4.1, 5.0.0 - 5.0.5
Parse error: parse error, unexpected '[', expecting ')' in /in/0tGOE on line 3
Process exited with code 255.
Output for 4.3.2 - 4.3.4
Parse error: parse error, expecting `')'' in /in/0tGOE on line 3
Process exited with code 255.