3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php fopen(); ?>
Output for 4.3.0 - 5.6.38, hhvm-3.10.1 - 3.11.1, hhvm-3.13.2, hhvm-3.18.4 - 3.21.3, 7.0.0 - 7.2.11
Warning: fopen() expects at least 2 parameters, 0 given in /in/tbmt1 on line 2
Output for hhvm-3.22.0
Warning: fopen() expects at least 2 parameters, 0 given in /in/tbmt1 on line -1
Output for hhvm-3.12.14, hhvm-3.15.4 - 3.17.3

Process exited with code 137.