3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php require_once 'https://raw.github.com/j4mie/idiorm/master/idiorm.php'; require 'https://raw.github.com/j4mie/paris/master/paris.php'; ORM::configure("sqlite:inclibs/sqlite3.db"); $db = ORM::get_db(); $db->exec("CREATE TABLE IF NOT EXISTS contact (id INTEGER PRIMARY KEY, name TEXT, email TEXT );" ); class Contact extends Model {} $contact = Contact::create(array('name' => 'nombre', 'email' => 'email'))->save(); $contact_list = Contact::find_many(); ?> <ul> <?php foreach ($contact_list as $contact): ?> <li><?php echo $contact->id; ?></li> <li> <strong><?php echo $contact->name ?></strong> <a href="mailto:<?php echo $contact->email; ?>"><?php echo $contact->email; ?></a> </li> <?php endforeach; ?> </ul>
Output for 5.4.15 - 5.6.21, 7.0.0 - 7.1.0
Warning: require_once(): https:// wrapper is disabled in the server configuration by allow_url_include=0 in /in/ov9U0 on line 2 Warning: require_once(https://raw.github.com/j4mie/idiorm/master/idiorm.php): failed to open stream: no suitable wrapper could be found in /in/ov9U0 on line 2 Fatal error: require_once(): Failed opening required 'https://raw.github.com/j4mie/idiorm/master/idiorm.php' (include_path='.:') in /in/ov9U0 on line 2
Process exited with code 255.
Output for hhvm-3.10.0 - 3.12.0
Fatal error: File not found: https://raw.github.com/j4mie/idiorm/master/idiorm.php in /in/ov9U0 on line 2
Process exited with code 255.
Output for 5.3.0 - 5.4.14
Warning: require_once(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/ov9U0 on line 2 Warning: require_once(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/ov9U0 on line 2 Warning: require_once(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/ov9U0 on line 2 Warning: require_once(https://raw.github.com/j4mie/idiorm/master/idiorm.php): failed to open stream: No such file or directory in /in/ov9U0 on line 2 Fatal error: require_once(): Failed opening required 'https://raw.github.com/j4mie/idiorm/master/idiorm.php' (include_path='.:') in /in/ov9U0 on line 2
Process exited with code 255.
Output for 5.1.0 - 5.2.17
Notice: require_once(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/ov9U0 on line 2 Warning: require_once(https://raw.github.com/j4mie/idiorm/master/idiorm.php): failed to open stream: No such file or directory in /in/ov9U0 on line 2 Fatal error: require_once(): Failed opening required 'https://raw.github.com/j4mie/idiorm/master/idiorm.php' (include_path='.:') in /in/ov9U0 on line 2
Process exited with code 255.
Output for 5.0.0 - 5.0.5
Notice: main(): Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /in/ov9U0 on line 2 Warning: main(https://raw.github.com/j4mie/idiorm/master/idiorm.php): failed to open stream: No such file or directory in /in/ov9U0 on line 2 Fatal error: main(): Failed opening required 'https://raw.github.com/j4mie/idiorm/master/idiorm.php' (include_path='.:') in /in/ov9U0 on line 2
Process exited with code 255.
Output for 4.4.2 - 4.4.9
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /in/ov9U0 on line 11
Process exited with code 255.
Output for 4.3.0 - 4.3.1, 4.3.5 - 4.4.1
Parse error: parse error, unexpected T_OBJECT_OPERATOR in /in/ov9U0 on line 11
Process exited with code 255.
Output for 4.3.2 - 4.3.4
Parse error: parse error in /in/ov9U0 on line 11
Process exited with code 255.