3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo version_compare('1.4.0', '1.4);
Output for 5.4.0 - 5.4.4
Parse error: syntax error, unexpected ''1.4);' (T_ENCAPSED_AND_WHITESPACE) in /in/n5A8q on line 2
Process exited with code 255.
Output for 5.3.0 - 5.3.14
Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE in /in/n5A8q on line 2
Process exited with code 255.