3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $foo = (float) (PHP_INT_MAX ); $foo *= 2; if ($foo == 1.844674407371E+19) { echo "true"; } else { echo "$foo != 1.844674407371E+19"; }
based on JsomE
Output for 4.4.0 - 4.4.9, 5.0.5 - 5.6.28, hhvm-3.12.0, 7.0.0 - 7.1.0
1.844674407371E+19 != 1.844674407371E+19
Output for hhvm-3.10.0

Process exited with code 153.
Output for 4.3.0 - 4.3.11, 5.0.0 - 5.0.4
Notice: Use of undefined constant PHP_INT_MAX - assumed 'PHP_INT_MAX' in /in/lXhIM on line 3 0 != 1.844674407371E+19