3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php try { if(PHP_MAJOR_VERSION<7) throw new Exception('PHP 7 or greater required!'); } catch(Exception $e) { echo $e->getMessage(); exit(); } echo "Hi!";
based on XWfVG
Output for 7.0.0 - 7.2.0
Hi!
Output for 5.3.18 - 5.6.28
PHP 7 or greater required!