3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo file_get_contents(popen('/bin/echo "hello";', 'r'));
based on mkF0n
Output for 5.4.0 - 5.6.28, 7.0.0 - 7.1.0
Warning: file_get_contents() expects parameter 1 to be a valid path, resource given in /in/igBmC on line 2
Output for 4.3.0 - 5.3.29, hhvm-3.10.0 - 3.12.0
Warning: file_get_contents() expects parameter 1 to be string, resource given in /in/igBmC on line 2