3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php file_get_contents('/dev/urandom', FALSE, NULL, -1, 100);
Output for 5.1.0 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
Output for 5.0.0 - 5.0.5
Warning: file_get_contents() expects at most 3 parameters, 5 given in /in/hpSQJ on line 3
Output for 4.3.0 - 4.4.9
Warning: file_get_contents() expects at most 2 parameters, 5 given in /in/hpSQJ on line 3