3v4l.org

run code in 300+ PHP versions simultaneously
<?php class A { public function T($a) { } } class B extends A { public function T(string $a) { } } echo "a";
Output for 8.0.0 - 8.0.22, 8.1.0 - 8.1.9
Fatal error: Declaration of B::T(string $a) must be compatible with A::T($a) in /in/gciem on line 11
Process exited with code 255.
Output for 7.4.0 - 7.4.30
Warning: Declaration of B::T(string $a) should be compatible with A::T($a) in /in/gciem on line 11 a
Output for 7.1.25 - 7.1.27, 7.2.0 - 7.2.33, 7.3.0 - 7.3.33
Warning: Declaration of B::T(string $a) should be compatible with A::T($a) in /in/gciem on line 15 a

preferences:
66.24 ms | 412 KiB | 5 Q