3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $string = preg_quote("\u00a0"); echo preg_replace('#(?:^[^\uL]*)|(?:[^\uL]*$)#u','',$string);
Output for 5.3.4 - 5.6.28, 7.0.0 - 7.1.0
Warning: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N{name}, \U, or \u at offset 7 in /in/eqEuE on line 3
Output for hhvm-3.10.0 - 3.12.0
Warning: Compilation failed: PCRE does not support \L, \l, \N{name}, \U, or \u at offset 7 in /in/eqEuE on line 3
Output for 5.2.3 - 5.3.3
Warning: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \U, or \u at offset 7 in /in/eqEuE on line 3
Output for 4.4.3 - 4.4.9, 5.0.5 - 5.2.2
<br /> <b>Warning</b>: preg_replace() [<a href='function.preg-replace'>function.preg-replace</a>]: Compilation failed: PCRE does not support \L, \l, \N, \U, or \u at offset 7 in <b>/in/eqEuE</b> on line <b>3</b><br />
Output for 5.0.0 - 5.0.4
<br /> <b>Warning</b>: preg_replace() [<a href='function.preg-replace'>function.preg-replace</a>]: Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 7 in <b>/in/eqEuE</b> on line <b>3</b><br />
Output for 4.4.0 - 4.4.2
<br /> <b>Warning</b>: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \U, or \u at offset 7 in <b>/in/eqEuE</b> on line <b>3</b><br />
Output for 4.3.11
<br /> <b>Warning</b>: preg_replace(): Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 7 in <b>/in/eqEuE</b> on line <b>3</b><br />
Output for 4.3.0 - 4.3.10
<br /> <b>Warning</b>: Compilation failed: PCRE does not support \L, \l, \N, \P, \p, \U, \u, or \X at offset 7 in <b>/in/eqEuE</b> on line <b>3</b><br />