3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php assert(false && 1 > 2 <=> 3); assert('false && 1 > 2 <=> 3');
based on VnEHD
Output for 7.2.0
Warning: assert(): assert(false && (1 > 2) <=> 3) failed in /in/cvJD5 on line 3 Deprecated: assert(): Calling assert() with a string argument is deprecated in /in/cvJD5 on line 4 Warning: assert(): Assertion "false && 1 > 2 <=> 3" failed in /in/cvJD5 on line 4
Output for 7.0.0 - 7.1.10
Warning: assert(): assert(false && (1 > 2) <=> 3) failed in /in/cvJD5 on line 3 Warning: assert(): Assertion "false && 1 > 2 <=> 3" failed in /in/cvJD5 on line 4
Output for 5.4.12 - 5.6.28
Parse error: syntax error, unexpected '<=' (T_IS_SMALLER_OR_EQUAL) in /in/cvJD5 on line 3
Process exited with code 255.
Output for 5.3.22 - 5.3.29
Parse error: syntax error, unexpected T_IS_SMALLER_OR_EQUAL in /in/cvJD5 on line 3
Process exited with code 255.