3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php $a = 'hello, [how]foo[how]bar. please don\'t remove [are] you?'; echo preg_replace('#\s*\[.+\]\s*#U', ' ', $a); echo PHP_EOL . "there should be no space between foo and bar :)";
Output for 4.3.10 - 4.4.9, 5.0.2 - 5.6.28, hhvm-3.10.0 - 3.12.0, 7.0.0 - 7.1.0
hello, foo bar. please don't remove you? there should be no space between foo and bar :)
Output for 4.3.0 - 4.3.9, 5.0.0 - 5.0.1
hello, foo bar. please don't remove you?PHP_EOLthere should be no space between foo and bar :)