3v4l.org

run code in 300+ PHP versions simultaneously
<?php function __autoload($class) { echo $class; } unserialize('O:8:"a/../s'."\x00".'a"::{}');
based on 3q0Fd
Output for 8.0.0
Fatal error: __autoload() is no longer supported, use spl_autoload_register() instead in /in/ZXX62 on line 3
Process exited with code 255.
Output for 7.2.0 - 7.2.33, 7.3.0 - 7.3.24, 7.4.0 - 7.4.13
Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /in/ZXX62 on line 3 Notice: unserialize(): Error at offset 6 of 18 bytes in /in/ZXX62 on line 7
Output for 4.3.11, 4.4.0 - 4.4.9, 5.0.4 - 5.0.5, 5.1.0 - 5.1.6, 5.2.0 - 5.2.17, 5.3.0 - 5.3.29, 5.4.0 - 5.4.45, 5.5.0 - 5.5.38, 5.6.0 - 5.6.40, 7.0.0 - 7.0.33, 7.1.0 - 7.1.33
Notice: unserialize(): Error at offset 6 of 18 bytes in /in/ZXX62 on line 7
Output for 5.0.0 - 5.0.3
a/../sa
Output for 4.3.0 - 4.3.10