3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php class Foo { function test($foo, array $bar) {} } class Bar extends Foo { function test($foo, $bar) {} }
Output for 7.0.0 - 7.1.0
Warning: Declaration of Bar::test($foo, $bar) should be compatible with Foo::test($foo, array $bar) in /in/ZMQGu on line 10
Output for hhvm-3.10.0 - 3.12.0
Output for 5.4.0 - 5.6.28
Strict Standards: Declaration of Bar::test() should be compatible with Foo::test($foo, array $bar) in /in/ZMQGu on line 10
Output for 5.1.0 - 5.3.29
Strict Standards: Declaration of Bar::test() should be compatible with that of Foo::test() in /in/ZMQGu on line 10
Output for 5.0.0 - 5.0.5
Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in /in/ZMQGu on line 5
Process exited with code 255.
Output for 4.4.2 - 4.4.9
Parse error: syntax error, unexpected T_ARRAY, expecting '&' or T_VARIABLE or T_CONST in /in/ZMQGu on line 5
Process exited with code 255.
Output for 4.3.0 - 4.3.1, 4.3.5 - 4.4.1
Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE or T_CONST in /in/ZMQGu on line 5
Process exited with code 255.
Output for 4.3.2 - 4.3.4
Parse error: parse error, expecting `'&'' or `T_VARIABLE' or `T_CONST' in /in/ZMQGu on line 5
Process exited with code 255.