3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php assert(PHP_MAJOR_VERION >= 7, new AssertionError('PHP 7 is requiered!'));
based on hn42Z
Output for 7.2.0
Warning: Use of undefined constant PHP_MAJOR_VERION - assumed 'PHP_MAJOR_VERION' (this will throw an Error in a future version of PHP) in /in/YNd8P on line 2 Warning: assert(): AssertionError: PHP 7 is requiered! in /in/YNd8P:2 Stack trace: #0 {main} failed in /in/YNd8P on line 2
Output for 7.0.0 - 7.1.10
Notice: Use of undefined constant PHP_MAJOR_VERION - assumed 'PHP_MAJOR_VERION' in /in/YNd8P on line 2 Warning: assert(): AssertionError: PHP 7 is requiered! in /in/YNd8P:2 Stack trace: #0 {main} failed in /in/YNd8P on line 2
Output for 5.3.18 - 5.6.28
Notice: Use of undefined constant PHP_MAJOR_VERION - assumed 'PHP_MAJOR_VERION' in /in/YNd8P on line 2 Fatal error: Class 'AssertionError' not found in /in/YNd8P on line 2
Process exited with code 255.