3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php assert_options(ASSERT_BAIL, true); assert_options(ASSERT_sdgdfsg, true); assert('version_compare(PHP_VERSION, "5.5.0", ">=")');
Output for hhvm-3.10.0, 7.0.0 - 7.1.0
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line 4 Warning: assert_options() expects parameter 1 to be integer, string given in /in/WjrsL on line 4
Output for hhvm-3.12.0
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line -1 Warning: assert_options() expects parameter 1 to be integer, string given in /in/WjrsL on line -1
Output for 5.5.24 - 5.6.28
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line 4 Warning: assert_options() expects parameter 1 to be long, string given in /in/WjrsL on line 4
Output for 5.3.0 - 5.4.45
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line 4 Warning: assert_options() expects parameter 1 to be long, string given in /in/WjrsL on line 4 Warning: assert(): Assertion "version_compare(PHP_VERSION, "5.5.0", ">=")" failed in /in/WjrsL on line 5
Output for 4.3.2 - 5.2.17
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line 4 Warning: assert_options(): Unknown value 0 in /in/WjrsL on line 4 Warning: assert(): Assertion "version_compare(PHP_VERSION, "5.5.0", ">=")" failed in /in/WjrsL on line 5
Output for 4.3.0 - 4.3.1
Notice: Use of undefined constant ASSERT_sdgdfsg - assumed 'ASSERT_sdgdfsg' in /in/WjrsL on line 4 Warning: assert_options() [http://www.php.net/function.assert-options]: Unknown value 0 in /in/WjrsL on line 4 Warning: assert() [http://www.php.net/function.assert]: Assertion "version_compare(PHP_VERSION, "5.5.0", ">=")" failed in /in/WjrsL on line 5