3v4l.org

run code in 150+ php & hhvm versions
Bugs & Features
<?php echo shell_exec('/bin/php-'. phpversion(). ' '. $_SERVER['PHP_SELF']);
Output for 5.3.9 - 5.6.28, 7.0.0 - 7.1.0
Output for hhvm-3.10.0 - 3.12.0
Failed to exec: `/bin/php-5.6.99-hhvm /in/VNVjo'