3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php declare (strict_types = 1); $doc = new \DOMDocument('1.0'); $doc->loadXML('<foo><bar>baz</bar></foo>'); $xpath = new \DOMXPath($doc); if (version_compare(PHP_VERSION, '7.0.2') === 0) { $node = $xpath->query('/foo')->item(0)->cloneNode(true); } else { $node = $xpath->query('/foo')->item(0)->cloneNode(1); }
based on Gp8E4
Output for 7.0.3 - 7.2.0
Fatal error: Uncaught TypeError: DOMNode::cloneNode() expects parameter 1 to be boolean, integer given in /in/RlGmZ:13 Stack trace: #0 /in/RlGmZ(13): DOMNode->cloneNode(1) #1 {main} thrown in /in/RlGmZ on line 13
Process exited with code 255.
Output for 7.0.0 - 7.0.2
Output for 5.3.21 - 5.6.28
Warning: Unsupported declare 'strict_types' in /in/RlGmZ on line 3