3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php $formula = <<<EOD =SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);".__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);".__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Non";VM(C29681)="Oui";VC(C29681)="Non";VM(C85755)="Oui";VC(C85755)="Oui");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ne couvre pas les garanties incapacité et invalidité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Non";VM(C85755)="Oui";VC(C85755)="Oui");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ne couvre pas la garantie invalidité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Non";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Oui");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ne couvre pas la garantie incapacité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Non";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Oui");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ne couvre pas la garantie PTIA.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Non";VM(C29680)="Oui";VC(C29680)="Non";VM(C29681)="Oui";VC(C29681)="Non";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);" et ne couvre pas les garanties PTIA, incapacité et invalidité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Non";VM(C29681)="Oui";VC(C29681)="Non";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);" et ne couvre pas les garanties incapacité et invalidité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Non";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);" et ne couvre pas la garantie invalidité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Oui";VM(C29680)="Oui";VC(C29680)="Non";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);" et ne couvre pas la garantie incapacité.__");SI(ET(VP("customer_french_resident")="Oui";VM(C29678)="Oui";VC(C29678)="Oui";VM(C29679)="Oui";VC(C29679)="Non";VM(C29680)="Oui";VC(C29680)="Oui";VM(C29681)="Oui";VC(C29681)="Oui";VM(C85755)="Oui";VC(C85755)="Non");CONCATENER("**L'offre individuelle ne maintient pas la couverture en cas de déplacement dans le monde entier à titre personnel, professionnel et humanitaire.** __Explication : Le contrat proposé en délégation ";VC(C85779);" et ne couvre pas la garantie PTIA.__");""))))))))))) EOD ; $fomule2 = '=SI(ET(VP("customer_french_resident")=12,5))))12.5;12,5;"12,5"'; $expression = preg_replace_callback('/(,)[?=(?:[^"]|"[^"]*")*$]/', function () { return '.'; }, $fomule2); var_dump(preg_last_error()); var_dump($expression);
Output for 7.2.11
Warning: preg_replace_callback(): Compilation failed: unmatched parentheses at offset 21 in /in/PEBT2 on line 12 int(1) NULL