3v4l.org

run code in 200+ php & hhvm versions
Bugs & Features
<?php phpversion() >= "7.0.1" or die(); $x = 'data'; echo $x['foo'];
based on BoDPi
Output for 7.0.1 - 7.2.0
Warning: Illegal string offset 'foo' in /in/OUPSp on line 5 d
Output for 5.3.21 - 7.0.0